package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<(.+)?class=\s*"(.+)?">`)
var str = `<h1 class="big blue" id="testing"> some text </h1>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}