$re = '/<(.+)?class=\s*"(.+)?">/m';
$str = '<h1 class="big blue" id="testing"> some text </h1>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);