package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:https?:\/\/)?(w{3}\.)?[\w_-]+((\.\w{2,}){1,2})(\/([\w\._-]+\/?)*(\?[\w_-]+=[^\?\/&]*(\&[\w_-]+=[^\?\/&]*)*)?)?$`)
var str = `http://www.teste.com.br/pasta/x/y/?q1=abc&q2=123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}