const regex = /^(?:https?:\/\/)?(w{3}\.)?[\w_-]+((\.\w{2,}){1,2})(\/([\w\._-]+\/?)*(\?[\w_-]+=[^\?\/&]*(\&[\w_-]+=[^\?\/&]*)*)?)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:https?:\\\/\\\/)?(w{3}\\.)?[\\w_-]+((\\.\\w{2,}){1,2})(\\\/([\\w\\._-]+\\\/?)*(\\?[\\w_-]+=[^\\?\\\/&]*(\\&[\\w_-]+=[^\\?\\\/&]*)*)?)?$', 'gm')
const str = `http://www.teste.com.br/pasta/x/y/?q1=abc&q2=123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}