import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?:\\/\\/)?(w{3}\\.)?[\\w_-]+((\\.\\w{2,}){1,2})(\\/([\\w\\._-]+\\/?)*(\\?[\\w_-]+=[^\\?\\/&]*(\\&[\\w_-]+=[^\\?\\/&]*)*)?)?$";
final String string = "www.teste.com.br/pasta/x/y/?q1=abc&q2=123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}