re = /^(?:https?:\/\/)?(w{3}\.)?[\w_-]+((\.\w{2,}){1,2})(\/([\w\._-]+\/?)*(\?[\w_-]+=[^\?\/&]*(\&[\w_-]+=[^\?\/&]*)*)?)?$/m
str = 'www.teste.com.br/pasta/x/y/?q1=abc&q2=123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end