package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(?:eur\w*|€)?\s*([0-9\., ]+)\s*(million)?\s*(?:eur\w*|€)?`)
var str = `EUR 7.200.000
euro 4 000
EUR 0.2 million
Main project: 300 000 EUR
1998: 43.000.000 euros`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}