$re = '/(^[a-zA-Z-]*)(\d{2}.\d{2}.\d{2}-\d{3})/m';
$str = 'vsc-nigulp-25.00.00-200.tar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);