re = /(^[a-zA-Z-]*)(\d{2}.\d{2}.\d{2}-\d{3})/m
str = 'vsc-nigulp-25.00.00-200.tar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end