package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<msgText>)([\s\S]*?)(<\/msgText>)`)
var str = `<msgText>H3ll0World</msgText><msgText>HelloWorld</msgText><otherTagWithNumbers>456</otherTagWithNumbers>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}