re = /(<msgText>)([\s\S]*?)(<\/msgText>)/
str = '<msgText>H3ll0World</msgText><msgText>HelloWorld</msgText><otherTagWithNumbers>456</otherTagWithNumbers>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end