$re = '/(\d+)(?=\w*<\/msgText>)/';
$str = '<msgText>H3ll0World</msgText><msgText>HelloWorld</msgText><otherTagWithNumbers>456</otherTagWithNumbers>
<msgText>ut4lk1nl1k3l33t0rwh4t</msgText>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);