re = /(\d+)(?=\w*<\/msgText>)/
str = '<msgText>H3ll0World</msgText><msgText>HelloWorld</msgText><otherTagWithNumbers>456</otherTagWithNumbers>
<msgText>ut4lk1nl1k3l33t0rwh4t</msgText>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end