using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?x)
#4...
#4+
#4{4}
#4{2,4} behave in a greedy way
#4{2,4}? behave in a non greedy way
#4{3,4}?
";
string input = @"4444";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}