$re = '/(?x)
#4...
#4+
#4{4}
#4{2,4} behave in a greedy way
#4{2,4}? behave in a non greedy way
#4{3,4}?
/m';
$str = '4444';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);