import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*::.*::)fe80(?=(?::+[^:]+){0,6}$)(?:(:0{1,4})*|(?1){3,}(?::+[^:]+)):(?=:)(:[0-9a-f]{1,4}){0,4}$|^fe80(?=(?::[^:]+){7}$)(?1){3,}(?2){0,4}$";
final String string = "valid cases:\n\n"
+ "FE80::1\n"
+ "FE80::1:0:1\n"
+ "FE80::0000:1\n"
+ "FE80:0::1\n"
+ "FE80:000::1\n"
+ "FE80:0:00::1\n"
+ "FE80:0:00:000::1\n"
+ "FE80:0:00:000:0000::1\n"
+ "fe80::9656:d028:8652:66b6\n"
+ "fe80:0000:0000:0000:0000:0000:0000:0000\n"
+ "fe80:00:000:0000:1234:5678:ABCD:EF\n"
+ "fe80:00:000:0000:1234:5678:ABCD:00\n"
+ "fe80::1234:5678:ABCD:EF\n"
+ "fe80:00:000:0000::EF\n"
+ "fe80:00::ABCD:EF\n"
+ "FE80:0:00:000:0001::1\n"
+ "FE80:0:00:000:0000:1::1\n\n"
+ "invalid cases:\n\n"
+ "fe80:66b6:9656:d028:8652:66b6:9656:d028:0000\n"
+ "fe80:66b6:9656:d028:8652:66b6:9656:d028\n"
+ "fe80:1:000:0000:1234:5678:ABCD:EF:9999\n"
+ "fe80::bad:1234:5678:ABCD:EF\n"
+ "fe80:0:bad::EF\n"
+ "fe80:1:2:3:4:6:5:7\n"
+ "fe80:0:bad:EF\n"
+ "Fe90::1\n"
+ "2000::1\n"
+ "fe80:00:000:0000:0:0:0::EF\n"
+ "fe80:0:0:0:ABCD:EF:0\n"
+ "FE80:0:00:001:0001::1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}