# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*::.*::)fe80(?=(?::+[^:]+){0,6}$)(?:(:0{1,4})*|(?1){3,}(?::+[^:]+)):(?=:)(:[0-9a-f]{1,4}){0,4}$|^fe80(?=(?::[^:]+){7}$)(?1){3,}(?2){0,4}$"
test_str = ("valid cases:\n\n"
"FE80::1\n"
"FE80::1:0:1\n"
"FE80::0000:1\n"
"FE80:0::1\n"
"FE80:000::1\n"
"FE80:0:00::1\n"
"FE80:0:00:000::1\n"
"FE80:0:00:000:0000::1\n"
"fe80::9656:d028:8652:66b6\n"
"fe80:0000:0000:0000:0000:0000:0000:0000\n"
"fe80:00:000:0000:1234:5678:ABCD:EF\n"
"fe80:00:000:0000:1234:5678:ABCD:00\n"
"fe80::1234:5678:ABCD:EF\n"
"fe80:00:000:0000::EF\n"
"fe80:00::ABCD:EF\n"
"FE80:0:00:000:0001::1\n"
"FE80:0:00:000:0000:1::1\n\n"
"invalid cases:\n\n"
"fe80:66b6:9656:d028:8652:66b6:9656:d028:0000\n"
"fe80:66b6:9656:d028:8652:66b6:9656:d028\n"
"fe80:1:000:0000:1234:5678:ABCD:EF:9999\n"
"fe80::bad:1234:5678:ABCD:EF\n"
"fe80:0:bad::EF\n"
"fe80:1:2:3:4:6:5:7\n"
"fe80:0:bad:EF\n"
"Fe90::1\n"
"2000::1\n"
"fe80:00:000:0000:0:0:0::EF\n"
"fe80:0:0:0:ABCD:EF:0\n"
"FE80:0:00:001:0001::1\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.