#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)((?<=\+)|(?=\+))|((?<=\-)|(?=\-))|((?<=\*)|(?=\*))|((?<=\/)|(?=\/))"
Local $sString = "3+2*2" & @CRLF & _
"23+3/32" & @CRLF & _
" 3/2 " & @CRLF & _
" 3+5 / 2 " & @CRLF & _
" 3+5 / 32*50 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")