$re = '/((?<=\+)|(?=\+))|((?<=\-)|(?=\-))|((?<=\*)|(?=\*))|((?<=\/)|(?=\/))/mx';
$str = '3+2*2
23+3/32
3/2
3+5 / 2
3+5 / 32*50 ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);