#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^G:.+)(\\)(.+)(.pdf$)"
Local $sString = "G:\Unidades compartidas\Auditoria Financiera IAF-FIP\01-2_Auditorias_en_ejecucion\Aud_presupuesto_2022\Documentos compartidos\Procedimientos KNIME contingencia\Contingencia pagos\Pagos Hacienda\Formularios\40_Formulario N40 Contabilización Propuestas de pago Andrea.pdf" & @CRLF & _
"G:\Unidades compartidas\Auditoria Financiera IAF-FIP\01-2_Auditorias_en_ejecucion\Aud_presupuesto_2022\Documentos compartidos\Procedimientos KNIME contingencia\Contingencia pagos\Pagos Hacienda\Formularios\29_Formulario propuesta de pago 029-2022.pdf" & @CRLF & _
"G:\Unidades compartidas\Auditoria Financiera IAF-FIP\01-2_Auditorias_en_ejecucion\Aud_presupuesto_2022\Documentos compartidos\Procedimientos KNIME contingencia\Contingencia pagos\Pagos Hacienda\Formularios\24_Formulario propuesta de pago 024-2022-1.pdf" & @CRLF & _
"G:\Unidades compartidas\Auditoria Financiera IAF-FIP\01-2_Auditorias_en_ejecucion\Aud_presupuesto_2022\Documentos compartidos\Procedimientos KNIME contingencia\Contingencia pagos\Pagos Hacienda\Formularios\14_Formulario propuesta de pago 014-2022 MDEH.pdf" & @CRLF & _
"G:\Unidades compartidas\Auditoria Financiera IAF-FIP\01-2_Auditorias_en_ejecucion\Aud_presupuesto_2022\Documentos compartidos\Procedimientos KNIME contingencia\Contingencia pagos\Pagos Hacienda\Formularios\40_Formulario N40 Contabilización Propuestas de pago Andrea.pdf" & @CRLF & _
"40-2022" & @CRLF & _
"MINISTERIO DE HACIENDA" & @CRLF & _
"DEPARTAMENTO FINANCIERO" & @CRLF & _
"FECHA DE PAGO (1) PROPUESTA (2) MONTO (3) FORMULARIO (4)" & @CRLF & _
"1/8/2022 0603I 2 212 400,00 AV. PAGOS CONTINGENTE T. DIGITAL (879152)" & @CRLF & _
"4/8/2022 0605I 1 67 000,00 AV. PAGOS CONTINGENTE T. DIGITAL (879877)" & @CRLF & _
"8/8/2022 0606I 1 661 500,00 AV. PAGOS CONTINGENTE T. DIGITAL (880938)" & @CRLF & _
"11/8/2022 0608I 492 000,00 AV. PAGOS CONTINGENTE T. DIGITAL (883036)" & @CRLF & _
"Combustible PAGOS CONTINGENTE T. DIGITAL" & @CRLF & _
"18/8/2022 06C10 12 398 383,03" & @CRLF & _
"(885351)" & @CRLF & _
"1 Fecha efectiva de pago en el sistema contingente fuera del SIGAF" & @CRLF & _
"2 Identificación de la propuesta de pago a crear en el sistema SIGAF, una vez renombrado los formularios" & @CRLF & _
"3 Importe neto de pago sin errores y devoluciones" & @CRLF & _
"4 Número de formulario utilizado para el pago contingente" & @CRLF & _
"5 Debe ser firmado por el director financiero o a quién éste delegue." & @CRLF & _
"FIRMA Andrea Montero Vásquez" & @CRLF & _
"Jefe a.i. Departamento Financiero" & @CRLF & _
"26/9/2022" & @CRLF & _
"2022-09-27T15:19:29-0600" & @CRLF & _
"ANDREA MONTERO VASQUEZ (FIRMA)" & @CRLF & _
"G:\Unidades compartidas\Auditoria Financiera IAF-FIP\01-2_Auditorias_en_ejecucion\Aud_presupuesto_2022\Documentos compartidos\Procedimientos KNIME contingencia\Contingencia pagos\Pagos Hacienda\Formularios\29_Formulario propuesta de pago 029-2022.pdf" & @CRLF & _
"29-2022" & @CRLF & _
"MINISTERIO DE HACIENDA" & @CRLF & _
"DEPARTAMENTO FINANCIERO" & @CRLF & _
"FECHA DE PAGO (1) FORMULARIO (4)" & @CRLF & _
"PROPUESTA (2) MONTO (3)" & @CRLF & _
"PAGOS CONTINGENTE T."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")