use strict;
my $str = 'G:\\Unidades compartidas\\Auditoria Financiera IAF-FIP\\01-2_Auditorias_en_ejecucion\\Aud_presupuesto_2022\\Documentos compartidos\\Procedimientos KNIME contingencia\\Contingencia pagos\\Pagos Hacienda\\Formularios\\40_Formulario N40 Contabilización Propuestas de pago Andrea.pdf
G:\\Unidades compartidas\\Auditoria Financiera IAF-FIP\\01-2_Auditorias_en_ejecucion\\Aud_presupuesto_2022\\Documentos compartidos\\Procedimientos KNIME contingencia\\Contingencia pagos\\Pagos Hacienda\\Formularios\\29_Formulario propuesta de pago 029-2022.pdf
G:\\Unidades compartidas\\Auditoria Financiera IAF-FIP\\01-2_Auditorias_en_ejecucion\\Aud_presupuesto_2022\\Documentos compartidos\\Procedimientos KNIME contingencia\\Contingencia pagos\\Pagos Hacienda\\Formularios\\24_Formulario propuesta de pago 024-2022-1.pdf
G:\\Unidades compartidas\\Auditoria Financiera IAF-FIP\\01-2_Auditorias_en_ejecucion\\Aud_presupuesto_2022\\Documentos compartidos\\Procedimientos KNIME contingencia\\Contingencia pagos\\Pagos Hacienda\\Formularios\\14_Formulario propuesta de pago 014-2022 MDEH.pdf
G:\\Unidades compartidas\\Auditoria Financiera IAF-FIP\\01-2_Auditorias_en_ejecucion\\Aud_presupuesto_2022\\Documentos compartidos\\Procedimientos KNIME contingencia\\Contingencia pagos\\Pagos Hacienda\\Formularios\\40_Formulario N40 Contabilización Propuestas de pago Andrea.pdf
40-2022
MINISTERIO DE HACIENDA
DEPARTAMENTO FINANCIERO
FECHA DE PAGO (1) PROPUESTA (2) MONTO (3) FORMULARIO (4)
1/8/2022 0603I 2 212 400,00 AV. PAGOS CONTINGENTE T. DIGITAL (879152)
4/8/2022 0605I 1 67 000,00 AV. PAGOS CONTINGENTE T. DIGITAL (879877)
8/8/2022 0606I 1 661 500,00 AV. PAGOS CONTINGENTE T. DIGITAL (880938)
11/8/2022 0608I 492 000,00 AV. PAGOS CONTINGENTE T. DIGITAL (883036)
Combustible PAGOS CONTINGENTE T. DIGITAL
18/8/2022 06C10 12 398 383,03
(885351)
1 Fecha efectiva de pago en el sistema contingente fuera del SIGAF
2 Identificación de la propuesta de pago a crear en el sistema SIGAF, una vez renombrado los formularios
3 Importe neto de pago sin errores y devoluciones
4 Número de formulario utilizado para el pago contingente
5 Debe ser firmado por el director financiero o a quién éste delegue.
FIRMA Andrea Montero Vásquez
Jefe a.i. Departamento Financiero
26/9/2022
2022-09-27T15:19:29-0600
ANDREA MONTERO VASQUEZ (FIRMA)
G:\\Unidades compartidas\\Auditoria Financiera IAF-FIP\\01-2_Auditorias_en_ejecucion\\Aud_presupuesto_2022\\Documentos compartidos\\Procedimientos KNIME contingencia\\Contingencia pagos\\Pagos Hacienda\\Formularios\\29_Formulario propuesta de pago 029-2022.pdf
29-2022
MINISTERIO DE HACIENDA
DEPARTAMENTO FINANCIERO
FECHA DE PAGO (1) FORMULARIO (4)
PROPUESTA (2) MONTO (3)
PAGOS CONTINGENTE T.';
my $regex = qr/(^G:.+)(\\)(.+)(.pdf$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}