import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w{3}\\s\\d{0,2}\\s[01][0-9]:[0-5][0-9]:[0-5][0-9]\\s[a-z]+\\skernel:\\smartian\\ssource\\s\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\sfrom\\s\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3},\\son\\sdev\\s\\w+\\n.+";
final String string = "Jan 10 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0\n"
+ "Jan 11 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5\n"
+ "Jan 12 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 13 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 14 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 15 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 16 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 17 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 18 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 19 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 20 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 21 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 22 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 23 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 23 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 24 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 25 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0\n"
+ "Jan 25 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5\n"
+ "Jan 26 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0\n"
+ "Jan 26 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5\n"
+ "Jan 27 10:12:45 server kernel: lo: Disabled Priacy Extensions\n"
+ "Jan 28 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0\n"
+ "Jan 28 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}