re = /\w{3}\s\d{0,2}\s[01][0-9]:[0-5][0-9]:[0-5][0-9]\s[a-z]+\skernel:\smartian\ssource\s\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}\sfrom\s\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3},\son\sdev\s\w+\n.+/m
str = 'Jan 10 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0
Jan 11 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5
Jan 12 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 13 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 14 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 15 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 16 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 17 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 18 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 19 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 20 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 21 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 22 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 23 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 23 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 24 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 25 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0
Jan 25 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5
Jan 26 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0
Jan 26 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5
Jan 27 10:12:45 server kernel: lo: Disabled Priacy Extensions
Jan 28 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0
Jan 28 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end