package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^>]+>){1,2}[^>]+`)
var str = `0001>0002>0003>0004>0005
0001>0002`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}