$re = '/^([^>]+>){1,2}[^>]+/m';
$str = '0001>0002>0003>0004>0005
0001>0002';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);