#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)href="https:\/\/my\.master\.com\/@([^\/]*)\/([^\/]*)\/([^\/]*)\/""
Local $sString = "href="https://my.master.com/@top-com/d/my-zen/"" & @CRLF & _
"href="https://my.master.com/@top-com/d/my-zen/my-zen/"" & @CRLF & _
"href="https://my.master.com/@top-com/d/my-zen/my-zen/my-zen/""
Local $sSubst = "href="https:__my.master.com_@$1_$2_$3_.html""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)