$re = '/href="https:\/\/my\.master\.com\/@([^\/]*)\/([^\/]*)\/([^\/]*)\/"/m';
$str = 'href="https://my.master.com/@top-com/d/my-zen/"
href="https://my.master.com/@top-com/d/my-zen/my-zen/"
href="https://my.master.com/@top-com/d/my-zen/my-zen/my-zen/"';
$subst = "href=\"https:__my.master.com_@$1_$2_$3_.html\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;