using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^ *#define +([a-zA-Z][\w]*)\( *([a-zA-Z_]\w*)(?: *, *([a-zA-Z_]\w*) *) *\) *(.+) *$";
string input = @" #define AD9D9( _Xy_ , Y9_y3 ) x + y + 3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}