package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(TRADE ACCOUNT BALANCE).*\$\s*(\d[\d,]*)`)
var str = `TRADE ACCOUNT BALANCE FROM 2 TRADE LINES CALL. .... $ 23,700`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}