$re = '/(TRADE ACCOUNT BALANCE).*\$\s*(\d[\d,]*)/m';
$str = 'TRADE ACCOUNT BALANCE FROM 2 TRADE LINES CALL. .... $ 23,700';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);