using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^dr.*(?<!last)(?<!statement)(?<!available)\.html$";
string input = @"/directory/index.html
/index.html
#
/index.html
/kss_how.html
dr_info/swearingenlarry.html
dr_info/swearingenlarrylast.html
dr_info/kingjohn.html
dr_info/kingjohnlast.html
dr_info/_coble.jpg
dr_info/coblebillielast.html
dr_info/netherystephen.jpg
dr_info/netherystephenlast.html
dr_info/rougeaupaul.jpg
dr_info/no_last_statement.html
dr_info/no_info_available.html
dr_info/no_last_statement.html
dr_info/no_last_statement.html
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}