use strict;
my $str = '/directory/index.html
/index.html
#
/index.html
/kss_how.html
dr_info/swearingenlarry.html
dr_info/swearingenlarrylast.html
dr_info/kingjohn.html
dr_info/kingjohnlast.html
dr_info/_coble.jpg
dr_info/coblebillielast.html
dr_info/netherystephen.jpg
dr_info/netherystephenlast.html
dr_info/rougeaupaul.jpg
dr_info/no_last_statement.html
dr_info/no_info_available.html
dr_info/no_last_statement.html
dr_info/no_last_statement.html
';
my $regex = qr/^dr.*(?<!last)(?<!statement)(?<!available)\.html$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}