using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{6}-(?=\d{4}$)0+([1-9]\d*)$";
string input = @"123456-0001
123456-0012
123456-0123
123456-001
123456-00001";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}