$re = '/^\d{6}-(?=\d{4}$)0+([1-9]\d*)$/m';
$str = '123456-0001
123456-0012
123456-0123
123456-001
123456-00001';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);