use strict;
my $str = 'nvsm-dshm-18.12-2.el7.noarch.rpm';
my $regex = qr/(^nvsm)(\-)(apis|dshm|cli)(\-|\_)(\d{2}|\(\d{2}\))(\.)(0?[1-9]|1[012])(\.|\-)(\d{1}|\d{2})(\-|\_|\.)(\d{1}|\d{2}|all|el\d{1})(\.)(el\d{1}|(deb)|(noarch))(|(\.)((x86_64)|(rpm))(\.)(rpm))$/imp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";