$re = '/(^nvsm)(\-)(apis|dshm|cli)(\-|\_)(\d{2}|\(\d{2}\))(\.)(0?[1-9]|1[012])(\.|\-)(\d{1}|\d{2})(\-|\_|\.)(\d{1}|\d{2}|all|el\d{1})(\.)(el\d{1}|(deb)|(noarch))(|(\.)((x86_64)|(rpm))(\.)(rpm))$/im';
$str = 'nvsm-dshm-18.12-2.el7.noarch.rpm';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;