#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)ID\s*:\s*(?<id>.+)Name\s*:\s*(?<name>.+)Date Of Birth\s*:\s*(?<dob>\w+)"
Local $sString = " ID: xxxxxxxx" & @CRLF & _
" Name: xxxxxxxxx " & @CRLF & _
" Date Of Birth : xxxxxxxx" & @CRLF & _
"" & @CRLF & _
" Regards," & @CRLF & _
" xxxxx xxxxx" & @CRLF & _
" xxxxxxxxxxxxxxxxxxxxxxxxxxxxx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")