import re
regex = re.compile(r"(?s)ID\s*:\s*(?<id>.+)Name\s*:\s*(?<name>.+)Date Of Birth\s*:\s*(?<dob>\w+)", flags=re.MULTILINE)
test_str = (" ID: xxxxxxxx\n"
" Name: xxxxxxxxx \n"
" Date Of Birth : xxxxxxxx\n\n"
" Regards,\n"
" xxxxx xxxxx\n"
" xxxxxxxxxxxxxxxxxxxxxxxxxxxxx")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")