package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[[^][]+]\((https?://[^()]+)\)`)
var str = `[https://imgur.com/abc](https://imgur.com/bcd) and [https://imgur.com/xyy](https://imgur.com/xyz)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}