re = /\[[^][]+]\((https?:\/\/[^()]+)\)/m
str = '[https://imgur.com/abc](https://imgur.com/bcd) and [https://imgur.com/xyy](https://imgur.com/xyz)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end