package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-zA-Z_]+ `)
var str = `foo$12___bar___$34wilma buzz
hello$ there 12 h___uhuhu$12 otherstuff
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}