// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\[(?<threadinfo>(?<threadtype>\w+)\s*-\s*(?<thread>\d+))\]\s*:\s*(?<timestamp>\d{1,2}\/\d{1,2}\/\d{4}\s*\d{1,2}:\d{1,2}:\d{1,2}[,\.]\d{1,3})\s*\|\s*(?<level>\w+)\s*\|\s*(?<body>.*)").unwrap();
let string = "[Thread-60]: 10/26/2020 02:33:41,178|DEBUG | --> Alarm thread ringing: com.nm.ross.client.xds.pab.XDSTxnProcessBroker$MonitorAlarmCallback";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}