import Foundation
let pattern = #"^\[(?<threadinfo>(?<threadtype>\w+)\s*-\s*(?<thread>\d+))\]\s*:\s*(?<timestamp>\d{1,2}\/\d{1,2}\/\d{4}\s*\d{1,2}:\d{1,2}:\d{1,2}[,\.]\d{1,3})\s*\|\s*(?<level>\w+)\s*\|\s*(?<body>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[Thread-60]: 10/26/2020 02:33:41,178|DEBUG | --> Alarm thread ringing: com.nm.ross.client.xds.pab.XDSTxnProcessBroker$MonitorAlarmCallback"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)