import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{1,63}$)(?!.*--)[a-zA-Z]([a-zA-Z0-9\\-]*[a-zA-Z0-9])?$";
final String string = "abc123\n"
+ "abc-123\n"
+ "123abc\n"
+ "a123456789012345678901234567890123456789012345678901234567890123\n"
+ "abc-123\n"
+ "abc--123\n"
+ "abc123-";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}