$re = '/^(?=.{1,63}$)(?!.*--)[a-zA-Z]([a-zA-Z0-9\-]*[a-zA-Z0-9])?$/m';
$str = 'abc123
abc-123
123abc
a123456789012345678901234567890123456789012345678901234567890123
abc-123
abc--123
abc123-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);