package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:1[89]|[2-9]\d) ?)?m(?: ?(?:1[89]|[2-9]\d))?$`)
var str = `m18
18m
m 18
18 m`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}