re = /^(?:(?:1[89]|[2-9]\d) ?)?m(?: ?(?:1[89]|[2-9]\d))?$/m
str = 'm18
18m
m 18
18 m'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end