package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\brecord {[^{}]*my_id_1[^{}]*}`)
var str = `record {
record {
id my_id_1
my_name_1
}
record {
id my_id_2
my_name_2
}
record {
id my_id_3
my_name_3
}
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}