import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\brecord \\{[^\\{\\}]*my_id_1[^\\{\\}]*\\}";
final String string = "record {\n"
+ " record {\n"
+ " id my_id_1\n"
+ " my_name_1\n"
+ " }\n\n"
+ " record {\n"
+ " id my_id_2\n"
+ " my_name_2\n"
+ " }\n\n"
+ " record {\n"
+ " id my_id_3\n"
+ " my_name_3\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}