# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<\w+)(\s*[\w-]+="[^"]+")*(\s*[\w-]+="[^"]+")*(\s*>)|(\w)|(<\\/\w+)*(\s*>)/$1$4$5$6$7/g;t' <<< "<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<td class=\"sky\" data-toggle=\"up\" id=\"heaven\" >
<a href=\"#\" data-toggle=\"modal\" data-target=\"xxxx\">xxxx</a>
<a href=\"#\"data-target=\"#available-assistance\" data-toggle=\"modal\" data-modal=\"yeah\"></a>
<a href=\"#\"data-target=\"#available-assistance\" data-toggle=\"modal\" data-modal=\"yeah\"></a>
"